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1 Introduction 

FlashPOM Designer is an application that enables user to design the chip layer by layer. Each layer 
has properties, like thickness, and contains set of geometrical shapes. One device can have multiple 
layers stacked upon the substrate layer.  

Software provides output in FPSVG file that is ready for chip fabricating process. Tools that helps user 
to design and visualize what she is designing are included. Key features are Cost functions that 
estimates cost of designed device, Check constraints, that checks whether chip is manufacturable, Cut 
View and 3D View, that visualize designed chip. 

This document guides potential user throughout the application, shows available tools and on a simple 
tutorial demonstrates typical use of the application. 
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2 Installation 

2.1 Prerequisites 

To run the application it is necessary to have correctly installed Microsoft .NET Framework Version 
2.0. For 3D View visualization function is required Microsoft DirectX 9.0 with Managed Extensions 
Library.  

Installation files for both libraries can be found at  

http://download.microsoft.com 

For .NET Framework version 2.0 search for .NET Framework version 2.0 Redistributable Package, 
for DirectX look for DirectX 9.0 Redistributable Package.  

2.2 Setup Wizard 

Program is distributed as a standard Microsoft Installation Package together with Setup program. 
Execute setup.exe to start the installation process.  

 

Figure 2-1: Installation files 

If previous version of the program is already installed warning window appears. It is necessary to 
uninstall old version using Add/Remove Programs from the Control Panel before installing new one. 

 

Figure 2-2: Program already installed 

The Setup Wizard will guide you through the installation process. After successful installation program 
shortcut is placed in the Windows Start menu (Start->Programs->FlashPOM Designer). 

 

Figure 2-3: Setup wizard 
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3 Application overview 

Screen of typical working environment is shown on figure. Window of the application consists of menu 
bar, tool bars, and tool windows, tabbed windows for chip design and status bar. All these parts can be 
moved or turned off to meet user requirements on their placement. Most of the commands are 
accessible from menu, toolbars and are also reachable using keyboard shortcuts. 

 

Figure 3-1: FlashPOM editor 

3.1 Main Menu 

Main Menu is a text menu with shortcuts to most functions of the application. Command shortcuts are 
placed to appropriate groups. 

 

Figure 3-2: Main Menu 

3.1.1 File 

New Ctrl N Creates a new empty chip design. Wizard that will guide user 
thorough entering necessary chip properties will pop-up. These 
include selection from available substrate materials and 
available layer materials. List of available materials is stored in 
configuration file that can be regularly updated over the internet. 

Open Ctrl O Opens an existing chip design from a previously saved file. 

Save Ctrl S Saves the currently active chip design on the file from which it 
was opened or on a new file if it was created from New. 
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Save As Ctrl Shift S Saves current chip design to different file than from which it was 
opened or most recently saved. 

Close Ctrl Q Closes active chip design project. 

Import from FPSVG  Imports chip design from the SVG like file. 

Export to FPSVG  Exports chip design to SVG like file which is to be loaded to 
laser device for chip fabricating. 

Recent Files 
 Contains files that were recently opened. 

Print Ctrl P Shows dialog for printing current chip design 

Exit Alt F4 Ends the application. 

3.1.2 Edit 

Undo Ctrl Z Undoes the most recently completed undoable command 

Redo Ctrl Y Redoes the most recently completed undoable command 

Cut Ctrl X Removes and copies currently selected element to windows 
clipboard. 

Copy Ctrl C Copies currently selected element to windows clipboard. 

Paste Ctrl V Inserts most recently cut or copied element from windows 
clipboard to active layer.  

Delete Del Removes currently selected element. 

Snap to Grid  Enables or disables snapping to Grid. 

Snap to Guidelines  Enables or disables snapping to Guidelines. 

3.1.3 View 

Rulers  Shows or hides Rulers in the chip design window. 

Grid  Shows or hides Grid in the chip design window. 

Guidelines  Shows or hides Guidelines in the chip design window. 

Zoom In Ctrl + Zooms in view on chip design window. 

Zoom Out Ctrl - Zooms out view on chip design window. 

Fit to Substrate Ctrl * Fits zoom such that whole substrate is visible. 

Zoom to Height  Zooms such that substrate fits the window on height. 

Zoom to Width  Zooms such that substrate fits the window on width. 
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3.1.4 Layer 

New Layer  Shows dialog window that guides user in adding new layer to 
active chip 

Delete Layer  Deletes active layer from the current chip design. 

3.1.5 Arrange 

Group Ctrl G Groups selected elements such they behave as a one unit. 

Ungroup Ctrl U Ungroup group to former elements. 

Ungroup All  Divides group tree to former elements, does not matter how 
many group commands were applied before (i.e. this is 
particularly helpful if user wants to break apart the group that 
was made of a group and element) 

Weld Ctrl W Combines selected elements to new one. 

Trim Ctrl T Trims selected element by another one. 

Intersect Ctrl I Produce new element that is a result of intersection of selected 
objects. 

Align Left  Aligns two elements such that left sides of respective bounding 
boxes coalesce. 

Align Right  Aligns two elements such that right sides of respective bounding 
boxes coalesce. 

Align Top  Aligns two elements such that top sides of respective bounding 
boxes coalesce. 

Align Bottom  Aligns two elements such that bottom sides of respective 
bounding boxes coalesce. 

Align Centers 
Horizontally 

 Aligns two elements such that centers of respective bounding 
boxes coalesce in horizontal direction. 

Align Centers 
Vertically 

 Aligns two elements such that centers of respective bounding 
boxes coalesce in vertical direction. 

3.1.6 Layer 

New Layer  Shows dialog window that guides user in adding new layer to 
active chip 

Delete Layer  Deletes active layer from the current chip design. 
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3.1.7 Tools 

Settings  Shows settings dialog where is possible to set working 
environment settings, such as color, length of history, default 
directories and settings of particular functions. 

Cut View Ctrl Shift C Shows window with visualization of the cut thorough the chip 
design. 

3D View Ctrl Shift 3 Shows window with 3D visualization of the chips design. 

Check Constraints  Checks current chip design whether it is ready for 
manufacturing. 

Estimate Chip Cost  Estimates price for current chip design. 

Update Production 
Settings File 

 Checks if there is new file with material definitions and laser 
device parameters available and offers the download of the file. 

Update the 
FlashPOM Editor 

 Checks whether new version of the software is available and 
offers the download. 

3.1.8 Window 

Library Ctrl Shift B Shows or hides Library tool window. 

Layers Ctrl Shift L Shows or hides Layers tool window, 

Properties Ctrl Shift P Shows or hides properties tool window. 

Standard  Shows or hides Standard toolbar. 

Creation Tools  Shows or hides Creation tools toolbar. 

Helpers  Shows or hides Helpers toolbar. 

Fast Settings  Shows or hides Fast Settings toolbar. 

Align  Shows or hides Align toolbar. 

Status bar  Shows or hides Status bar. 

Reset Window 
Positions 

 Sets tool window positions to default values. 

3.1.9 Help 

About  Shows dialog window with common information about the 
application, 

User Reference  Opens this document. 
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3.2 Tool windows 

3.2.1 Layers 

 

Figure 3-3: Layers tool window 

The Layers tool window provides view on all chip layers. Appearance of each layer (color, 
transparency, visibility) in chip design window can be set there. There is also possibility to lock layer to 
avoid unwanted element manipulation.  

Order of layers can be changed by Up/Down buttons or by drag and drop. 

New layer can be added or deleted by New/Delete button. 

3.2.2 Properties 

 

Figure 3-4: Properties tool window 

Purpose of the properties window is to show and allow user to modify properties of selected object 
(chip, layer, element, grid, guide line). List box is filled with flatten list of all objects which properties 
can be changed.  
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3.2.3 Library 

 

Figure 3-5: Library tool window 

The Library tool window manages user element libraries. New library is created by New button. 
Existing library stored on different than default location can be loaded by Open button. Created library 
is deleted by Delete button. 

Any element can be inserted into created library by selecting element and pressing Insert button. 
Element can be placed to chip layer by Place button or by drag and drop. Elements can be also 
deleted from the library by Delete button. 

3.3 Toolbars 

3.3.1 Standard 

 

Figure 3-6: Standard toolbar 

Standard toolbar provides fast access to key functions of the application. 

3.3.1.1 File tools 

 

Figure 3-7: New project 

 

Figure 3-8: Open project 

 

Figure 3-9: Save project 

New project runs new project wizard that guides user to create new chip design with one layer.  

 

Figure 3-10: New chip design 

Name of new chip design is arbitrary and when saving is used as a default file name. Substrate 
material is used as a base of the chip. In the next step user is forced to enter parameters of the first 
layer. 

Open project and Save project opens dialog window for opening/saving chip design. 
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3.3.1.2 New Layer 

 

Figure 3-11: New layer 

New layer command opens dialog for adding new layer to chip design. User can enter arbitrary name. 
Layer thickness must fall within the range of available thicknesses for selected material.  

 

Figure 3-12: New layer dialog 

3.3.1.3 Clipboard tools 

 

Figure 3-13: Cut 

 

Figure 3-14: Copy 

 

Figure 3-15: Paste 

 

Figure 3-16: Distribute 

Clipboard tools are standard functions working with clipboard. Cut moves selected element to windows 
clipboard. Copy makes copy of selected element and this copy is inserted to the clipboard. Paste puts 
element in the clipboard to selected layer. 

 

Figure 3-17: Distribute dialog 

Distribute function helps user to make copies of selected element placed into rectangular array. 
Number of copies in horizontal/vertical direction is to be set in distribute dialog. Horizontal/vertical 
distance between respective copies can be set there as well. User can choose whether the distance is 
measured as a distance between element centers or as a distance between element bounding box 
borders. 
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3.3.1.4 Undo/redo 

 

Figure 3-18: Undo 

 

Figure 3-19: Redo 

Undo/redo commands undoes/redoes performed action. Number of undo/redo steps can be set in 
Settings (Tools->Settings->Project->History->Length). 

3.3.1.5 Select element 

 

Figure 3-20: Select and edit 

 

Figure 3-21: Select by name 

When user wants to move or edit element it has to be selected first. To select element or group of 
elements by pointing at them by mouse use the select and edit tool. 

Actions to be done to select one element: 

 Activate Select and edit tool 

 Move mouse cursor on the element  

 Click mouse left button 

Other elements can be added to selection. If selection contains more than one element it is considered 
as a temporary group. 

Actions to be done to add element to selection: 

 Move mouse cursor on the element to be added to selection 

 Press shift key and click mouse left button together 

 
Figure 3-22: Select by name dialog 
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Another approach to select more elements is to use selection rectangle.  

Actions to be done to select group of elements by selection rectangle: 

 Activate Select and edit tool 

 Select selection rectangle start point, hold left mouse button 

 Select selection rectangle end point, release mouse button 

Another approach to select elements is to use Select by name dialog box. Start typing element name 
into the text box or click on the name in list box. Amount of displayed element names can be restricted 
to elements on selected layer by checking Only active layer checkbox. 

3.3.1.6 Zoom 

 

Figure 3-23: Zoom area 

In many cases it is useful to magnify some detail of the design. Zoom ratio can be chosen from 
predefined values in the zoom combo box. At the same place zoom value can be entered directly.   

Another option is to magnify selected rectangular area. 

Actions to be done: 

 Activate Zoom area tool 

 Select zoom rectangle start point, hold mouse left button 

 Select zoom rectangle end point, release mouse button 

3.3.1.7 Move working area 

 

Figure 3-24: Move working area 

This function moves working area.  

Actions to be done: 

 Activate Move working area function 

 Locate mouse cursor on any position on the workspace 

 Hold mouse left button and move the mouse 

 When the workspace is on the intended position, release mouse button 

3.3.1.8 Take snapshot 

 

Figure 3-25: Take snapshot 

Take snapshot command saves current workspace as a picture. 

3.3.2 Creation tools 

 

Figure 3-26: Creation tools toolbar 

Creation tools toolbar contains functions for creating new elements, combining new elements and 
rotating them. 



 - 12 - 

3.3.2.1 New element 

 

Figure 3-27: New line 

 

Figure 3-28: New rectangle 

 

Figure 3-29: New ellipse 

New element tools add line, rectangle or ellipse to selected layer.  

Actions to be done: 

 Activate New element tool from the toolbar 

 Select element start point, hold mouse left button 

 Select element end point, release mouse button 

3.3.2.2 Boolean operations 

 

Figure 3-30: Weld 

 

Figure 3-31: Trim 

 

Figure 3-32: Intersect 

Boolean operation tools combine two objects to new one. Resulting element is of type path. 

Actions to be done: 

 Select first element  

 Activate Boolean operation tool from the toolbar 

 Select second element 

Boolean operations 

Ctrl W Weld 

Ctrl T Trim 

Ctrl I Intersect 

3.3.2.3 Flip 

 

Figure 3-33: Flip horizontally 

 

Figure 3-34: Flip vertically 

Flip tools flips the selected object around the element centre horizontally/vertically. 

3.3.2.4 Rotate 90° 

 

Figure 3-35: Rotate 90° clockwise 

 

Figure 3-36: Rotate 90° counter-clockwise 

Rotate tools rotates the selected object 90° clockwise/counter-clockwise around the element center. 

3.3.3 Fast settings 

 

Figure 3-37: Fast settings toolbar 

Fast settings toolbar allows user to enter nudge distance and grid distance parameters directly what is 
faster than entering them in the Settings (Tools->Settings dialog). 
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3.3.3.1 Nudge distance 

 

Figure 3-38: Nudge distance 

When element is selected user can move it by pressing cursor keys. The distance object is moved is 
called nudge distance and can be entered directly using fast setting toolbar. 

3.3.3.2 Grid distance 

 

Figure 3-39: Grid distance 

Grid distance is the interval between respective horizontal and vertical grid lines. 

3.3.4 Align  

 

Figure 3-40: Align toolbar 

Align toolbar contains functions to align one element to another.  

Actions to be done: 

 Select object to be aligned 

 Activate Align function either from toolbar or by pressing keyboard shortcut 

 Select the reference object you are aligning to 

Align 

Ctrl Alt L Align Left 

Ctrl Alt R Align Right 

Ctrl Alt T Align Top 

Ctrl Alt B Align Bottom 

Ctrl Alt H Align Centers Horizontally 

Ctrl Alt V Align Centers Vertically 

3.3.5  Helpers 

Helpers are tools that helps user with precise element selection and positioning tasks. They can be 
found in Helpers toolbar. 

 

Figure 3-41: Helpers toolbar 

3.3.5.1 Select elements inside selection rectangle only 

 

Figure 3-42: Select elements inside selection rectangle only 

Using rectangular selection user can select objects that are intersected by the selection rectangle as 
well as objects that are inside. While this option is turned on only objects inside rectangular selection 
are selected.  
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Figure 3-43: Distinction between Select elements inside selection rectangle only turned on (left) and off (right) 

3.3.5.2 Rulers  

 

Figure 3-44: Show/hide rulers 

Rulers are handy tool that is displayed along the workspace by default. It gives user better feeling 
about size and distances between elements. 

 

Figure 3-45: Rulers 

3.3.5.3 Grid 

 

Figure 3-46: Show/hide grid 

 

Figure 3-47: Snap to grid 

Another helper that gives user better feeling about distances is grid. It draws rectangular grid on the 
workspace. Grid distance can be adjusted by user in the Fast Settings toolbar or in the Settings 
(Tools->Settings->Project). 

What makes grid useful is function of snapping to grid. Mouse cursor is snapped to grid lines while 
creating or editing elements thus user can perform these actions precisely. Snapping points of element 
are at corners and in the centre of the element. These are used during translation. 

 

Figure 3-48: Bottom right corner is snapped to grid while resizing the rectangle 
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3.3.5.4 Guidelines 

 

Figure 3-49: Show/hide guidelines 

 

Figure 3-50: Snap to guidelines 

Guidelines are lines that can be placed by user on any position on the workspace. To insert new 
horizontal or vertical guideline on workspace click mouse right button on horizontal or vertical ruler, 
move the mouse to appropriate position then release the mouse button.  

User can select guideline by right mouse click. Selected guideline is displayed in properties window 
where precise position can be set as well as orientation and its name. 

To delete a guideline right click mouse on it, move back above the ruler and release the mouse button. 

Similarly to grid, mouse cursor is snapped to guidelines while creating or editing elements what 
enables user to perform these actions precisely. 

 

Figure 3-51: Bottom right corner is snapped to guidelines while resizing the rectangle 

3.3.5.5 Cross cursor 

 

Figure 3-52: Show/hide cross cursor 

Cross cursor is another tool that can help user in certain situations. It draws cursor horizontal and 
vertical line above the whole workspace. 

 

Figure 3-53: Cross cursor 
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4 Tutorial: First chip design 

This tutorial guides user step by step when creating new chip design. Desired chip contains of 
substrate RPyrex layer and two SU-8_2100 layers. 

 

Figure 4-1: Sketch of the chip 

Start up with creating New chip design/project. There are three possible ways to do that. First one is 
New (File->New) command in the main menu. Second is keyboard shortcut (Ctrl N) and the last one is 
(New Project) button in the Standard toolbar. 

 

Figure 4-2: New project 

New chip design wizard appears. In the first step enter chip name, in this case My Chip, and select 
appropriate substrate material, here RPyrex. Finally pres OK button to continue. 

 

Figure 4-3: New chip design dialog 

In the second step parameters of first chip layer are to be entered. Enter first layer name, in this case 
Layer One. Then select material of the layer, here SU-8_2100, and enter thickness which value must 
fall in range of Minimum-Maximum thickness defined by selected material, here 100um.  
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Figure 4-4: New layer dialog 

Prepare your workspace. Desired chip design has smallest parts of size 100um thus appropriate grid 
distances should be 50um. Fastest way to set grid distance is in Fast Settings toolbar. Then magnify 
the workspace using zoom area tool so you can see enough detail while designing the chip. 
Recommended zoom value is about 150x for chip of the size 700um, however zoom value depends on 
the size of monitor you are using.  

 

Figure 4-5: Setting the workspace 

Finally move the workspace such the top left corner of substrate active border will be in the top left of 
the workspace. 

 

Figure 4-6: Move working area 

Draw rectangle of size 300um x 300um at position 5.2mm; 5.2mm using New Rectangle tool. 

 

Figure 4-7: New rectangle 

Snap to grid function snaps your mouse cursor that helps you enter the rectangle at proper position of 
exact size. As well, you can draw rectangle of any size at any position and then enter the proper 
values at the properties tool window. 
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Figure 4-8: Draw rectangle, size: 300um x 300um, location: 5.2mm; 5.2mm 

Draw circle with radius 50um at position 5.2mm; 5mm using New Ellipse tool. 

 

Figure 4-9: New ellipse 

 

Figure 4-10: Draw ellipse, radius: 50um x 50um, location: 5.2mm; 5.2mm 

We want to create path element that will arise from welding the rectangle and ellipse together. Draw 
rectangle of size 150um x 10um at any position 5.45mm; 5.05mm, using New Rectangle tool. 
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Figure 4-11: Draw rectangle, size: 150um x 10um, location: 5.45mm; 5.05mm 

Align rectangle to ellipse such that centers will be vertically aligned. Select the rectangle, activate 
Align Centers Vertically function by button on Align toolbar, or press (Ctrl Alt V) keyboard shortcut, 
and select the ellipse. 

 

Figure 4-12: Align centers vertically 

When object are aligned weld them together. Select the rectangle then activate Weld tool by button on 
Creation Tools toolbar, or press (Ctrl W) keyboard shortcut, and select the ellipse. 

 

Figure 4-13: Weld 

By welding new element of type path will arise. 

 

Figure 4-14: Ellipse and rectangle welded together 

Copy the path object, keyboard shortcut (Ctrl C), and paste it, keyboard shortcut (Ctrl V). Move path to 
position 5.4mm 5mm by mouse, it should snap to grid, or set the location value directly in the 
properties.  

Another possible solution is to select the path and perform Align Right function. 
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Figure 4-15: Paste path at position: 5.4mm; 5mm 

Select both paths, copy them, rotate 180 degrees and move under the main rectangle. Enable Select 
and edit tool from standard toolbar. Now you can select multiple objects by selection rectangle or by 
clicking each element you want to select with shift key pressed.  

Perform copy and paste, (Ctrl C) and (Ctrl V) keyboard shortcut.  

Rotate two pasted object 180 degrees. Rotation of selected elements can be done by left click on 
green filled glyph and moving the mouse, while Ctrl key is pressed value is added/subtracted in 15 
degrees step. As well you can enter rotation value directly in the properties tool window.  

Move rotated paths to position 5.2mm; 5.5mm. 

 

Figure 4-16: Selection pasted, rotated 180 degrees and moved to position 5.2mm; 5.5mm 

Select all paths. Perform copy and paste. Rotate selection 90 degrees. 
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Figure 4-17: Paths copy pasted and rotated 90 degrees 

For all paths select main rectangle, activate Weld tool, and select the path. This way you will get all 
elements welded together to one element of type path. 

 

Figure 4-18: Weld all elements together 

Add layer two by pressing New Layer button on Standard toolbar, on Layers tool window or by 
command (Layer->Add) in the Main menu. New layer dialog appears. Enter the name Layer Two and 
thickness and material the same as for Layer One. 
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Figure 4-19: Layers tool window 

In Layers tool window current chip layers are displayed. By left mouse click you can select active 
layer, the one where elements can be created and edited. 

Finally draw rectangle of size 300um x 300um at position 5.2mm; 5.2mm and four ellipses of radius 
50um at positions: 5.2mm; 5mm, 5.4mm; 5mm, 5mm; 5.2mm, 5.6mm; 5.2mm, 5mm; 5.4mm, 5.6mm; 
5.4mm, 5.2mm; 5.6mm, 5.4mm; 5.6mm. 

 

Figure 4-20: Finished chip 

Finished device can be saved by (File->Save) command in Main menu, keyboard shortcut (Ctrl S) or 
exported to FPSVG file for manufacturing by (File->Export to FPSVG) command in Main menu.  

But maybe it is better to check whether designed chip does not contain any errors using Check 
Constraints function or to see what we designed using 3D View or Cut View visualization. 
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5 Program tools/functions 

5.1 Edit element 

Selected element can be moved, resized or rotated. These element edit tasks can be performed by 
mouse or user can select exact values for respective transforms in the properties tool window. 

 

Figure 5-1: Selected element 

To move element hold left mouse key and move the mouse. If you want to move element in horizontal 
or vertical direction only, hold Ctrl key. Resize the element by holding left mouse button on one of the 
white filled ellipse glyphs and move the mouse. If Ctrl key is pressed size of the element is changed 
proportionally. Hold left mouse button on the green filled ellipse glyph to rotate the object. Holding Ctrl 
key means rotation angle change in 15 degrees steps.  

 

Figure 5-2: Move 

 

Figure 5-3: Resize 

 

Figure 5-4: Transform 
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5.2 Cut view 

Cut view is a visualization function that gives user better feeling about how layers are stacked on each 
other. When Cut View window is enabled in menu (Tools->Cut View) or by keyboard shortcut (Ctrl 
Shift C) cutline appears on the workspace area. By Select and edit tool cutline can be selected and 
moved. In the Properties tool window exact position can be entered and orientation selected. Cut 
view window dynamically reacts to cut line position change and shows cut thorough the layers of the 
chip. 

 

Figure 5-5: Cut View window 

Cut View provides following tools: 

 Show Details When turned on in attached tooltip shows 
information about element under mouse 
cursor. 

 
Horizontal Zoom Zoom in horizontal direction. 

 
Vertical Zoom Zoom in vertical direction. 

 Zoom Area Magnify selected rectangular area. 

 Move Working Area Moves working area. 

 Constant Layer Thickness Sets thickness of all layers to entered 
one. 

 Take Snapshot Takes snapshot of current working area. 

 Show/Hide Rulers Shows or hides rulers. 
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5.3 3D View 

3D View is a visualization function that offers three-dimensional view on designed chip. Visualization 
can be started from menu (Tools->3D View) or by keyboard shortcut (Ctrl Shift 3). On startup, dialog 
that informs that you need to have most recent Direct3D library with Managed extensions installed 
appears. You can also opt if all chip layers should have the same thickness a select whether you want 
to show this dialog again. 

 

Figure 5-6: 3D View start up dialog 

When you confirm the dialog window 3D View visualization starts. This can take some time for more 
complex designs.  

 

Figure 5-7: 3D View window 

On the right side bar user is encouraged to select which layer should be visualized, can customize 
rendering options and take snapshot and save it to the file. 
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View control: 

Hold left mouse button + mouse move Rotate 

Hold right mouse button + mouse move Move 

Mouse Wheel Zoom 

 

Move 

W Move Up 

S Move Down 

A Move Left 

D Move Right 

 

Rotate 

Shift W Rotate Up 

Shift S Rotate Down 

Shift A Rotate Left 

Shift D Rotate Right 

 

Zoom 

+ Zoom In 

- Zoom Out 
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5.4 Check constraints 

Check constraints function helps user to identify cases that should cause problems during chip 
manufacture. Tool can be started from menu (Tools->Check constraints). Following situations can be 
tested.  

5.4.1 Layer compatibility 

Checks whether only layers made of compatible materials are stacked on each other. 

5.4.2 Element is placed out of layer boundary 

Test whether elements are placed inside active substrate/layer boundary. These elements will not be 
manufactured. 

 

Figure 5-8: Element out of layer boundary 

5.4.3 Element overlaps layer boundary 

Test whether elements are lay on active substrate/layer boundary. Only part of these elements should 
be manufactured. 

 

Figure 5-9: Element overlaps layer boundary 
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5.4.4 Elements are overlapping within one layer 

Check whether two elements are overlapping within one layer. This should prevent laser device to 
shot one place more times in manufacturing process. 

 

Figure 5-10: Elements are overlapping within one layer 

5.4.5 Element in upper layer is without support in lower layer 

Test whether element in upper layer has support in lower layer. If not such an element wil most 
probably flow away. 

 

Figure 5-11: Element in lower layer is without support in lower layer 
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5.4.6 Element in upper layer has only particular support in lower layer 

This warning means that layer in upper layer has only particular support in lower layer. This should 
catch user attention. 

 

Figure 5-12: Element in lower layer has only particular support in upper layer 

5.5 Settings 

Settings tool window can be opened by (Tools-Settings) command from Main menu. It provides 
possibility to change settings that are unique to project and saved together with chip design as well as 
settings that are global for the application.  

 

Figure 5-13: Settings dialog 
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5.6 Estimate Chip cost 

Estimate chip cost function computes chip manufacturing price for designed chip. Tool can be started 
by (Tools->Estimate Chip Cost) command from Main menu.  

 

Figure 5-14: Estimate chip cost 

Equations for computing cost of the chip are the following: 

layers layers

rfaceelementssuepriceunitsurfaclayerpricericesubstratepchipprice *  

Figure 5-15: Equation for cheap price with negative layers 

layers layers

rfaceelementssuepriceunitsurfaccepricewholesurfalayerpricericesubstratepchipprice )*(

Figure 5-16: Equation for chip price with positive layers. 

5.7 Update 

(Tools->Update Production Settings File) and (Tools->Update the FlashPOM) editor are tools that 
checks whether new version of the production settings file or application is available.  

 

Figure 5-17: Update the application 



 - 31 - 

5.8 Print 

Print dialog can be invoked by (File->Print) command in Main menu or by (Ctrl P) keyboard shortcut. It 
provides settings for appearance of pages to be printed. User can select margins of the page, zoom of 
the chip, whether only one chip layer should be printed on one page and opt to print layer info. 

 

Figure 5-18: Print dialog 

It is also possible to invoke standard Windows dialogs to choose he printer and select paper size. 
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6 Appendix 

6.1 Keyboard Shortcuts 

File 

Ctrl N New 

Ctrl O Open 

Ctrl S Save 

Ctrl Shift S Save As 

Ctrl Q Close 

Ctrl P Print 

Alt F4 Exit 

 

Edit 

Ctrl Z Undo 

Ctrl Y Redo 

Ctrl X Cut 

Ctrl C Copy 

Ctrl V Paste 

Del Delete 

 

View 

Ctrl + Zoom In 

Ctrl - Zoom Out 

Ctrl * Fit to Substrate 
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Arrange 

Ctrl G Group 

Ctrl U Ungroup 

Ctrl W Weld 

Ctrl T Trim 

Ctrl I Intersect 

 

Align 

Ctrl Alt L Align Left 

Ctrl Alt R Align Right 

Ctrl Alt T Align Top 

Ctrl Alt B Align Bottom 

Ctrl Alt H Align Centers Horizontally 

Ctrl Alt V Align Centers Vertically 

 

Tools 

Ctrl Shift C Cut View 

Ctrl Shift 3 3D View 

 

Window 

Ctrl Shift B Library 

Ctrl Shift L Layers 

Ctrl Shift P Properties 

 

New Element 

Ctrl Rectangle Proportional size (Square) 

Ellipse Proportional size (Circle) 
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Edit Element 

Ctrl Rotation Step 15 degrees 

Size Proportional size change 

Move Move in vertical or horizontal 
direction only 
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6.2 Files Location 

6.2.1 Program Files 

Program files location is selected by user during installation process. By default it is: 

c:\Progam Files\FlashPOM Designer\ 

6.2.2 FlashPOM Designer Settings 

The FlashPOM.exe.config file that contains default program settings is located in the same folder as 
program files.  

Settings modified by user are stored in: 

C:\Documents and Settings\[user name]\Local Settings 
\ApplicationData\UWB\FlashPOM.exe_Url_[id]\[version]\user.config 

6.2.3 Production Settings File 

The ProductionSettings.xml file that contains information about laser device capabilities and available 
materials is stored in the isolated storage at: 

C:\Documents and Settings\All Users\Application Data\Isolated Storage\[id]\Url.[id]\AssemFiles\ 

This file can be updated over the internet directly from the application. 

6.2.4 Library files 

Library files are stored in: 

C:\Documents and Settings\All Users\Application Data\FlashPOM\Library 

 


